For the following tutorials download shapefiles from www.diva-gis.org/gdata:

  • United States Administrative areas (USA_adm.zip)
  • Andora Administrative areas (AND_adm.zip) (takes less storage space for free accounts)

Log in to Map Editor account with your existing GIS Cloud credentials or sign up.

Create a new map

  1. Select Home tab.
  2. Click Create New Map button.
  3.  

    Untitled

     

  4. Add map name and choose a basemap.
  5. Click Save button.
  6.  

    create a new map

 

Uploading data to the GIS Cloud

Before creating a new map you have to upload data from your computer to GIS Cloud with the File manager. You can also create a new layer and populate it with data. Please note that layers created in GIS Cloud are stored in the Database Manager.

  1. Open File manager from the Tools tab.
  2.  

    NMT_DatabaseManager_GeospatialFile

     

  3. Click Upload button.
  4.  

    file manager

     

  5. Click Add files button or Drag & drop files USA_adm.zip or AND_adm.zip for free accounts.
  6. Click Close after the upload is completed.
  7.  

    NMT_1Tutorial4

Transfering data into the database

To perform features editing or data analysis, the layers you’re working with must reside in the database. The Database Manager allows you to import layers from the File Manager into the database.

  1. Click Tools tab and click Database Manager icon.
  2. Click Import Geospatial file icon.
  3.  

    NMT_DatabaseManager_Import_UI

     

  4. Select layer you want to import (or upload it to the GIS Cloud).
  5. Click Select button.
  6. Write table name. 

     

    Note: When naming table:

    • start with a letter or an underscore (_)
    • use only English alphabet letters, digits and underscores
    • use only lower case

     

    NMT_DBImport

     

    • Overwrite existing – Overwrites existing table with the same name
    • Explode collections – Explodes multigeometry features to the geometry (i.e. multipolygons to polygons)
    • Skip failures – Skips features that can’t be imported to the database

     

  7. After choosing layer and defining options click Import button.

Note: make sure that layer has UTF-8 encoding.

Adding layers

Layers can be added from several sources: local computer/File System, Database, Web Map Service, Tile Map Service (Open Street Maps, Mapbox etc.), GIS Cloud Maps, Mobile Devices and/or Arcmap extension.

Layers brought to GIS Cloud via a shapefile, kml etc. are stored in the file manager. Those layers will not be editable until they are imported in the database and added to a map. Data collected with Mobile Data Collection app is automatically stored in the table in the database. If you want to add MDC layer to your map, use Database as a datasource.

  1. Select Add Layer from the Map tab.
  2. Select Database source and add USA_adm1 shapefile.
  3.  

    Note: for multiple selection hold Ctrl key on your keyboard.

     

    source manager

     

  4. Select Add Layer again and now choose Tile Map Service as a Datasource and select Open Street Map.

Note: only layers added to a map from the Database datasource are editable. If you need to edit layers, add them to the Database and when adding layers select Database as a datasource as shown before.

Import Layer from XLS or CSV file

If you have data geocoded with location coordinates you can upload it as an Excel table or CSV. This data can then be visualized as a layer.

  1. Download the tutorial XLS file to your computer: tutorial.xls.
  2. Upload tutorial.xls file to the GIS Cloud as shown before.
  3. Go to the Layer Tab and select Import CSV or XLS.
  4. Click Select a file button and upload tutorial.xls file to the GIS Cloud.
  5.  

    tut_imp_xls

     

  6. Define X field as Longitude and Y as Latitude.
  7. Click Import.
  8. Add layer as shown before (Layer tab->Add Layer->Database datasource).

 

 

Click here to view the map in Map Viewer.