If you have location coordinates data, you can upload it as an Excel table (XLS) or CSV. This data can then be imported and added to a map as a layer.

Prepare data

Data table has to have this structure, otherwise system won’t be able to recognize the data:

  • Make sure that a table doesn’t have a complex formatting (merged cells, double header, more sheets, font color etc.). Export your table as .csv and open table in common text editor (e.g. Notepad++).
  • Latitude and longitude has to have WGS84 projection format (e.g.: 16.4986, -20.7458).
  • Header must not contain any spaces, use underscore (_) instead of space e.g. street_name,house_number,name_of_owner
  • Make sure that column separator is comma (,) and not semicolon (;) e.g. Flatlands Ave, Brooklyn, NY 11234, USA.
  • First row (header) has to contain column title and all other columns have to contain data.
  • For the header names use only English alphabet letters, digits and underscores (_).
  • Use full-stop as a delimiter for decimal numbers.

 

Capture

 

Import data

Click here for a quick video tutorial.

  1. Go to Layer Tab or or open Database Manager.
  2. Select Import CSV or XLS function.
  3.  

    png3

     

  4. Browse for the uploaded XLS or CSV in File Manager.
  5. Set the table parameters, select the coordinate fields and click Import.
  6.  

    png4

     

List of parameters

  1. File – name of the original file which data will be imported in the database
  2. Table name – name of the table stored in Database
  3. Import as – spatial table means that data will have coordinates, and the points will be displayed on the map. If table is imported as non-spatial table, only attribute data will be stored.
  4. Import action:
    • Overwrite – if there is a table with the same name in the database, the new table will overwrite the old one.
    • Append to – if there is a table with the same name in the database, a new table will contain both old and new attribute data.
    • Replace – will replace the old table with the new one.
  5. Longitude – from the drop down list select a column that contains longitude data.
  6. Latitude – from the dropdown list sesect a colum that contains latitude data.
  7. Visible – uncheck the field if you don’t want to import it
  8. Type – select column type in which original data is. String is used for text, Integer for whole numbers and Real for decimal numbers.
  9. Back to upload – navigates to the upload window.

Add XLS or CSV table on a map

The imported tables are stored in Database and can be displayed on the map.

  1. Go under Layer tab.
  2. Tap Add Layer option.
  3. Choose Database as a Datasource and browse your imported XLS or CSV.
  4.  

    png5

    Troubleshooting

    All points are located in Atlantic ocean, near Africa

    There are several possible causes for points located near Africa. In general, this means that system couldn’t recognize the geometry and located points at coordinates 0,0.

    • Check the import parameters for X and Y. Select the correct fields for latitude and longitude and try to import the layer again.
    •  

      xy

       

    • Check the coordinates format. All coordinates have to be written in WGS84 projection format e.g. 13.2656,16.2657. If the coordinates in the table are in some other e.g. local projection, reproject them first in WGS84, upload the table to GIS Cloud and try again.
    •  

      incorrect coordinates

    Invalid file encoding

    This message indicates that the file is has invalid encoding. There are various encodings and they depend on the language and special characters. Open the table in some spreadsheet application and save it with default UTF-8 encoding.

    encoding

    The uploaded file is not visible in Source Manager when selecting the file for import

    This indicates that uploaded file is XLSX or some other unsupported format. Save the file as CSV or XLS and upload it to GIS Cloud again.

    Unsupported characters

    The import can also fail if there are unsupported characters in column names e.g. &%$#/() or spaces. Delete them from the column names and replace with the underscore (_). Upload the file and try again.

    See also:

    Tutorial 1: Upload, prepare and add data